Skocz do zawartości
tomek83

Czujnik indukcyjny.

Polecane posty

Wybrane dla Ciebie

tomek83    15

Witam.

Chciałbym zainstalować czujnik indukcyjny do sterownika od prasy aby określał prędkość oraz powierzchnię wykonanej pracy. Moje pytanie brzmi: czy to ma być czujnik pnp czy npn. Mam pnp ale kiedy go podłączam pod kostkę zasilającą to dioda się świeci, po oddaleniu od metalu przygasa ale na wyświetlaczu nic nie wskazuje. Dodam że jak podłączę drugi czujnik (który jest od liczenia balotów) to prędkość wyświetla się prawidłowo, więc chyba coś nie tak jest z tym czujnikiem.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach



Gość Profil usunięty   
Gość Profil usunięty

Musisz sprawdzić jaki jakiego typu jest czujnik, który działa. Są dwwa typy: NPN i PNP i każdy z nich może być NO lub NC. Spróbuj na próbę odwrócić fazę tego PNP, którego masz za pomocą przekaźnika i zobacz czy działa.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

maks    82

Jesteś w stanie zobaczyć kolory przewodów tej drugiej czujki? Jeśli tak, to podłącz zasilanie tak:

niebieski - masa

brązowy - +12V

czarny - sygnał

i miernikiem sprawdz co sie pojawia na sygnale jak zblizysz cos metalowego do czujki. Bedzie to albo masa (czujka NPN) albo +12V (czujka PNP). Potem bedziesz określał czy NO (normalnie otwarty, gdy nic zbliżasz metalu to sygnału nie będzie, po zbliżeniu pojawi sie sygnał) czy NC (normalnie zwarty - bez zblizania bedzie podawał sygnał, po zbliżeniu sygnał zniknie).

 

NO czy NC nie jest aż tak ważne, z jednym i drugim typem będzie działać, ale jak podepniesz czujkę PNP zamiast NPN to możesz już prędkości nie zmierzyć (bo mógł się uszkodzić procesor).

 

Jak wyłapiesz co to sa czujka to będziesz też wiedział, które piny we wtyczce do czego są, kupujesz nową i montujesz i bangla ;)

Edytowano przez maks

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

tomek83    15

Dzięki Waszym podpowiedziom doszedłem do wniosku, że oba czujniki są PNP bo na sygnale jest +12v. Różnica między czujnikami polega tylko na tym, że ten kupiony jest NO bo sygnał jest przy zbliżeniu do metalu a powinienno być odwrotnie, bo przy starym czujniku sygnał jest po oddaleniu od metalu.

Zmuszony jestem kupić czujnik PNP NC, czy można coś zrobić z tym co mam???

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

maks    82

W zasadzie powinno to zadziałać jak podłączysz.

Zakładając, że prędkość była obliczana w momencie gdy przed czujkę "wchodziła" szpilka, to teraz będzie to następowało przy jej "uciekaniu". Spróbuj podłaczyć tak jak podłaczona jest tamta i zobacz, czy zadziała. Powinno.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

tomek83    15

Pokombinowałem dzisiaj trochę i zaczęło przeskakiwać na sterowniku i dioda gaśnie całkowicie ale po zmostkowaniu przewodu (-) z przewodem od sygnału. Natomiest czoło czujnika w żaden sposób nie chce reagować na metal. Czujnik indukcyjny zachowuje się jak krańcowy. Dlaczego?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

maks    82

Coś mi tu nie gra. Czujka NO podaje sygnał tylko, gdy metal jest w zasięgu jej działania. Mówisz, że coś przeskakuje, czyli wydaje się, że sygnał dociera.

Sprawdź jeszcze raz, jaki jest ten czujnik który jest przy prasie, czy na pewno jest to PNP NC.

 

Nie możesz zwierać masy z sygnałem. A jeśli dioda na czujniku nie gaśnie do końca, to może to wynikać ze specyfiki samego czujnika. Ja mam takie czujniki (NO), że jeden po podłączeniu do kontrolera nie świeci w stanie spoczynku i świeci gdy wykrywa, a drugi świeci lekko w stanie spoczynku a "pełną mocą" świeci gdy coś wykrywa. A obydwa są podłączone tak samo. A wynika to po prostu z budowy wewnętrznej czujki, bo działać działa poprawnie.

 

Więc jeśli u Ciebie prędkośc pokazuje, ale ta dioda nie gaśnie do końca to ja bym tego nie ruszał skoro działa.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

tomek83    15

Czujnik przy prasie to kontaktronowy bo reaguje na magnes. Sprawdziłem kontrolką, że na sygnale chyba jednak jest masa, bo kiedy czujnik jest w zasięgu magnesu to żarówka się pali a gdy odchylę to żarówka gaśnie i na sterowniku przeskoczy.

 

A z tym nowym jest taka sytuacja dziwna że jak go podłączę tak samo jak tego starego to nie można tego stwierdzić, bo nie pali się ani na (+) ani na (-).

Kiedy nie jest zmostkowany to dioda pali się tak jak u Ciebie, gdy odsunę od metalu lekko a kiedy zbliżę to pełnym blaskiem i reakcji na sterowniku nie ma żadnej.

Kiedy zmostkuję (-) i sygnał to dioda pali się pełną mocą gdy przerwę mostek dioda gaśnie całkowicie i przeskoczy na sterowniku. Bez względu na to czy czoło czujnik jest przy metalu czy nie.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

maks    82

No to jeśli jest masa na wyjściu tamtego czujnika to on jest jednak NPN i PNP nie będzie działać.

 

Sprawdź to tak, że jakimś drucikiem podawaj masę we wtyczce od sterownika z konektora masy na konektor sygnału. Jeśli wtedy będzie przeskakiwać na wyświetlaczu (mogą pojawiać się baaardzo duże prędkości) to znaczy, że ten czujnik na pewno był NPN.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

tomek83    15

A to jest prawidłowe, że jak podłączę ten nowy czujnik PNP pod (+) i (-) kostki sterownika to na sygnale nie można określić czy jest (+), czy (-)?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

maks    82

W stanie jałowym może tak być jeśli jest to czujka NO (a taką masz) - bo nie zwiera, a jak nie zwiera (tzn nie podaje sygnału +12V) to na jej wyjściu jest pewien stan nieustalony - coś pomiędzy masą a +12V, ale nie wiadomo konkretnie co. Analogicznie jest przy czujkach NPN - gdy zwiera to na sygnale na pewno jest masa, a gdy nie zwiera to coś pomiędzy masą a napięciem zasilania.

Dlatego przy konstrukcji takich zabawek zaleca się odpowiednią ich budowę, żeby takie stany ograniczyć.

 

Sprawdź tak jak napisałem to będzie wszystko wiadomo. Ale zapewne będziesz musiał się kopnąć do sklepu i wymienić na czujkę NPN.

Edytowano przez maks

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

tomek83    15

Po podłączeniu czujnika (tego starego) do kostki sterownika i kontrolki a później zmostkowaniu (-) i sygnał zauważyłem, że na sterowniku nic nie przeskakuje (czy czujnik jest w zasięgu magnesu czy nie) a w chwili zwarcia żarówka kontrolki zapala się jaśniejszym blaskiem.

 

Po odłączeniu czujnika a jedynie zmostkowaniu (-) i sygnał na sterowniku przeskakuje o 1 tylko w chwili zwarcia, więc w tym momencie ten stary NPN zachowuje się tak samo jak PNP w chwili zwarcia (-) i sygnał.

 

Mimo to, zainwestuję jednak w czujnik NPN, który polecasz NO, czy NC?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Sadek    448

To jeżeli tak się zachowuje to może zastosować właśnie kontaktron.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Gość Profil usunięty   
Gość Profil usunięty

Po podłączeniu czujnika (tego starego) do kostki sterownika i kontrolki a później zmostkowaniu (-) i sygnał zauważyłem, że na sterowniku nic nie przeskakuje (czy czujnik jest w zasięgu magnesu czy nie) a w chwili zwarcia żarówka kontrolki zapala się jaśniejszym blaskiem.

 

Po odłączeniu czujnika a jedynie zmostkowaniu (-) i sygnał na sterowniku przeskakuje o 1 tylko w chwili zwarcia, więc w tym momencie ten stary NPN zachowuje się tak samo jak PNP w chwili zwarcia (-) i sygnał.

 

Mimo to, zainwestuję jednak w czujnik NPN, który polecasz NO, czy NC?

 

 

 

Jeżeli sterownik reaguje na zwarcie wejścia sygnałowego z masą to znaczy, że odpowiedni będzie czujnik NPN NO.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

tomek83    15

To jeżeli tak się zachowuje to może zastosować właśnie kontaktron.

 

 

Wolę zainstalować indukcyjny bo nie potrzeba magnesów.

 

Dziękuję wszystkim za pomoc i zainteresowaniem tematem.

Odezwę się jak już zdobędę ten czujnik i pochwalę się reakcją.

Pozdrawiam!

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

tomek83    15

Witam, czujnik działa znakomicie!

 

Teraz pozostaje jeszcze tylko problem wykalibrowania sterownika do prawidłowej prędkości. W sterowniku jest zakres od 10 do 5000, nie wiem w jakich to jest wartościach?

Teoretycznie z kalkulatorem w ręku, przy kole o obwodzie 5,65m i 8 szpilek na koło przy sygnale co 1 sek. wyliczyłem, że prędkość powinna być +/- 2,54 km/h, więc sterownik zaprogramowałem na 140.

 

Wiecie może skąd to się wzięło?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

maks    82

142 powinieneś wklepać.

 

5,65 / 8 = 0,70625 m na jeden impuls.

100m (typowy dystans kalibracji) / 0,70625 ~ 141,59 ~142.

 

A nie ma tam funkcji kalibracji? Bo najlepiej to po prostu przejechać się po polu latem i wtedy wynik będzie miarodajny, bo zawsze opona może się ugiąć, lekko usiąść w glebie nie wspominając o jej zużyciu. Takie obliczenia są czysto teoretyczne, a w praktyce raczej coś innego wyjdzie. Do samej prędkości to nie ma takiego aż znaczenia, bo różnica będzie w granicach kilku dziesiątych km/h, ale przy obliczaniu powierzchni w dłuższej perspektywie błąd będzie widoczny.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

tomek83    15

Dokładnie kolego o to mi chodziło.

W sumie to i tak wyliczyłem to dużą dokładnością nie wiedząc co z czym i dlaczego.

Właśnie o te 100 m chodziło i tak zrobię jak napisałeś.

 

Dzięki wielkie!!!

Duże jasne z pianką dla wszystkich a 2 dla Ciebie.

Pozdrawiam!!!

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się


  • Podobna zawartość

    • Przez mkkk
      Moja ladowarka w czasie jazdy gaśnie. Przejrzałem cały układ paliwa, nowa pompka,filtr, czujnik na pompie wtryskowej,elektryk sprawdził instalację. Pozostała mi chyba pompa wtryskowa do sprawdzenia.Czy ktoś może mi poradzić?
    • Przez radek5314
      Czy ktos moze polecic dobra chemie do mycia ciagnikow i maszyn  przed zima, cos mniej zracego niz Dimer, chodzi tu o zaschniete błoto?
    • Przez wesolyzetor
      Problem dotyczy chłodni do mleka Wsk Krosno , dzieje się to od pewnego czasu chodzi o to że agregat w chłodni raz się sam włącza prawidłowo a nieraz nie (trzeba uruchomić samemu) co to może być ?
    • Przez patryk159
      Witam bardzo serdecznie wszystkich!
      Tak jak w temacie prosze wszystkich którzy mieli lub widzieli gdzies na stronie www wszelkiego rodzaju pomoce naukowe pomocne w nauce elektroniki ciągnikowej. prosze podawac linki/pliki pdf. Z góry dziekuje:D
       
    • Przez Krol295
      Witam od okolo tygodnia w new hollandzie 8560 ford wentylator nie chcial sie zalączać po zapaleniu ciagnika gdy sie uderzylo piescia gdzies pod wentylator zaczal chodzic . Jednak wczoraj podczas pracy ciagnika wentylator stanał, najpierw chodzil jak by nie mial sily i od tamtej pory nie da sie go uruchomic a jak da to zaraz znowu przestanie. Czy da rade to naprawic czy pozostaje kupno nowego ?
×